W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2010

[Bug 10304] New: Rename "remove" method on object store to "delete"

From: <bugzilla@jessica.w3.org>
Date: Fri, 06 Aug 2010 12:36:58 +0000
To: public-webapps@w3.org
Message-ID: <bug-10304-2927@http.www.w3.org/Bugs/Public/>

           Summary: Rename "remove" method on object store to "delete"
           Product: WebAppsWG
           Version: unspecified
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Indexed Database API
        AssignedTo: nikunj.mehta@oracle.com
        ReportedBy: kris@sitepen.com
         QAContact: member-webapi-cvs@w3.org
                CC: mike@w3.org, public-webapps@w3.org

Based on the mailing list discussion, it was generally agreed that we could
rename the "remove" method on the object store API back to it's original name
of "delete". This was originally renamed due to EcmaScript reserved word
concern, but since all implementations are targeting EcmaScript 5, and "delete"
is contextually unreserved in ES5, the use of "delete" is perfectly fine, and
the most clear word for the action of the method.

Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Friday, 6 August 2010 12:37:00 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:13:10 UTC