Comments on View Modes

Hi there!

Here you have some of my comments on the current view mode spec, which
I have added support for in WebKit.

With regard to the media feature


I believe the 'all' is is not that useful as that is the same as not
declaring anything. This comment has been given by others.

With regard to the other modes, I find the 'mini' name very confusing
as it refers to a docking state, and many people confuse 'floating'
and 'mini' because of this.

The 'application' mode doesn't sounds like a view mode but more like a
state. Suggestions could be 'windowed' or maybe 'standalone'. But
maybe instead we should go for something like: "docked", "floating",
"minimized", "normal" and "maximized". Those really seem like view
modes to me.

The mode "minimized" might seem useless at first, but I added for completeness.

As you can query the view mode from javascript, it might be possible
to use it to purge resources from javascript when the app is
minimized; but that requires having the dom events in place.

I also think it would be good to define Chrome better in the spec, or
maybe define Window Decorations, as I believe that a widget in
'application' mode should not have chrome but window decorations from
the "window manager".

With regard to the VM Interface:


I beleive it should not be called ViewModeChanged but ViewModeChange,
just like we have "show", "hide" today and not "shown", "hidden". Same
with MediaTypeChangedEvent. Opera also seem to use "change" and not
"changed" in their original widget implementation.

We also need an API for requesting view mode changes from JavaScript.
It is important here that it is a request as not all widgets support
all view modes.


Kenneth Rohde Christiansen
Technical Lead / Senior Software Engineer
Qt Labs Americas, Nokia Technology Institute, INdT
Phone  +55 81 8895 6002 / E-mail kenneth.christiansen at ﹆﹆﹆

Received on Thursday, 1 April 2010 13:14:43 UTC