Re: ISSUE-99 (listen): Add shorter method names for addEventListener, et al? [DOM3 Events]

On Fri, 28 Aug 2009 11:19:54 +0200, Robin Berjon <> wrote:
> On Aug 27, 2009, at 11:46 , Sergey Ilinsky wrote:
>> Starting shortening member names can open the Pandora box. What about  
>> getElementsByTagName, querySelector etc.? I think at this point of time  
>> it is better to avoid such an initiative.
> Because? And why at this point in time? Will it become okay next week?
> We collectively made some pretty bad naming decisions in the past,  
> fixing them is both harmless and useful.

I don't really agree.  It would dramatically increase the number of tests  
required, you would get pages that do not work in older browsers for no  
reason other than using a "better" name, the complexity of the platform  

Authors would all have to learn the new methods, how they differ (if we  
decide to make minor cosmetic changes). Future authors would be left  
wondering why the old method exist, etc. And maybe further in the future  
they decide to do the big renaming thing again because well, our names  
were not so consistent after all.

If you want a much cleaner platform than what browsers provide you can  
write it on top of what browsers provide. Hopefully we get XBL soon as  
that will make such things much easier and neater.

Anne van Kesteren

Received on Friday, 28 August 2009 09:32:14 UTC