RE: [widgets] A revised proposal on widget modes

Many thanks for the feedback - comments inline.



>-----Original Message-----
>From: [] 
>On Behalf Of timeless
>Sent: 21 February 2009 18:28
>To: Priestley, Mark, VF-Group
>Cc: public-webapps
>Subject: Re: [widgets] A revised proposal on widget modes
>On Thu, Feb 19, 2009 at 3:36 PM, Priestley, Mark, VF-Group 
><> wrote:
>> I'm not stuck on the names of the viewmodes and their 
>respective elements.
>> For example, I am inclined to agree with one of the earlier comments 
>> that "maximised" might be a better name for "fullscreen".
>i'd like to offer a preemptive veto of maximised. it's not the 
>correct spelling in en-US, and anything which is likely to be 
>misspelled is a bad start.

Fine by me

><viewmodes default="floating/fullscreen/docked">
>it's hard to tell if you mean that you can specify one of 
>those, or if / is ok. And there's the minor issue of what 
>happens if a certain WUA only supports some of the modes and 
>the widget is only allowed to specify one.

Sorry - my example wasn't clear. I meant that the widget author could
declare the widgets preferred mode of operation, therefore they would
only specify a single value which would be one of the defined keywords.

>I think i'd rather startview="x,y" where there's some rule for 
>whether the first or last supported view is handled.
>I'd probably prefer:
>    <mode name="floating" height="300" width="500"/>
>    <mode name="fullscreen" max-height="500" max-width="600"/>
>for the child element, i suspect it's easier to deal w/ validation.

Marcos has pointed out some other issues with specifying height and
width and so this probably needs rethinking anyway. However, if not, I
agree your proposal is preferable.

Received on Monday, 23 February 2009 15:27:47 UTC