W3C home > Mailing lists > Public > public-webapps-testsuite@w3.org > May 2012

Fwd: Re: New tests submitted by Microsoft for WebApps specs

From: Ms2ger <ms2ger@gmail.com>
Date: Sun, 06 May 2012 11:57:03 +0200
Message-ID: <4FA64AEF.1040008@gmail.com>
To: public-webapps-testsuite <public-webapps-testsuite@w3.org>, David Levin <levin@google.com>
David,

The correct venue to discuss WebApps' test suites is 
public-webapps-testsuite@w3.org.

Thanks
Ms2ger

-------- Original Message --------
Subject: Re: New tests submitted by Microsoft for WebApps specs
Resent-Date: Sun, 06 May 2012 09:47:37 +0000
Resent-From: public-webapps@w3.org
Date: Sun, 6 May 2012 02:46:40 -0700
From: David Levin <levin@google.com>
To: Travis Leithead <Travis.Leithead@microsoft.com>
CC: Adrian Bateman <adrianba@microsoft.com>,  "Web Applications Working 
Group WG (public-webapps@w3.org)" <public-webapps@w3.org>, Israel 
Hilerio <israelh@microsoft.com>,  Brian Raymor 
<Brian.Raymor@microsoft.com>, Kris Krueger <krisk@microsoft.com>

Looks like the WorkerGlobalScope_ErrorEvent_*.htm tests are still in error
as mentioned below.

dave


On Tue, Sep 20, 2011 at 10:53 AM, Travis Leithead <
Travis.Leithead@microsoft.com> wrote:

>  Thanks! We’ll see about getting these updated…****
>
> ** **
>
> *From:* David Levin [mailto:levin@google.com]
> *Sent:* Monday, September 19, 2011 6:33 PM
> *To:* Adrian Bateman
> *Cc:* Web Applications Working Group WG (public-webapps@w3.org); Israel
> Hilerio; Travis Leithead; Brian Raymor; Kris Krueger
> *Subject:* Re: New tests submitted by Microsoft for WebApps specs****
>
> ** **
>
> ** **
>
> On Tue, Sep 13, 2011 at 6:26 PM, Adrian Bateman <adrianba@microsoft.com>
> wrote:****
>
> WebWorkers (51 tests/assertions)
>  Changeset: http://dvcs.w3.org/hg/webapps/rev/7b0ba70f69b6
>  Tests: http://w3c-test.org/webapps/Workers/tests/submissions/Microsoft/**
> **
>
>
> * We believe the tests are all accurate but look forward to wider review
> from
>  the group. IE10 PP3 does not pass all the tests and we are working to fix
>  the bugs that cause failures.****
>
>  Web Worker test issues:****
>
> ** **
>
> issue 1:****
>
> WorkerGlobalScope_ErrorEvent_*.htm uses the onerror function and expected
> to get an error event but instead it should get 3 arguments.
>
> See
>
> http://www.whatwg.org/specs/web-apps/current-work/complete/workers.html#runtime-script-errors-0
> and****
>
>
> http://www.whatwg.org/specs/web-apps/current-work/complete/webappapis.html#report-the-error
> ****
>
> ** **
>
> issue 2:****
>
> ** **
>
> postMessage_clone_port_error.htm expects to get INVALID_STATE_ERR but
> should expect to get DATA_CLONE_ERR.****
>
> ** **
>
>
> http://www.whatwg.org/specs/web-apps/current-work/multipage/comms.html#posting-messages
> ****
>
> ** **
>
Received on Sunday, 6 May 2012 09:57:36 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:52:55 UTC