public-webapps-bugzilla@w3.org from July 2013 by subject

[Bug 14949] [Meta]: Component Model needs an Explainer document

[Bug 14968] [Meta]: Specify how custom elements work

[Bug 14974] [Meta]: Provide a detailed overview of the component model

[Bug 14978] [Meta]: Specify how shadow DOM works

[Bug 15157] [Custom Elements]: Add an example testing an element for the right prototype

[Bug 15200] HTMLCollection string methods should return multiple matches

[Bug 15222] [Shadow]: Specify physics of apply-shadow-styles

[Bug 15476] [Templates]: Specify how templates work

[Bug 15480] [Shadow]: Things to Consider in the Future

[Bug 15497] [Shadow]: Research implementer's feedback on cloning shadow DOM subtrees

[Bug 15551] Consider attribute forwarding

[Bug 15616] [Shadow]: Consider augmenting HTML parser behavior to allow <shadow> and <content> anywhere

[Bug 15817] [Shadow]: Look at Windows 8 controls as shadow DOM use cases

[Bug 15818] [Shadow]: Consider a notion of shared stylesheet

[Bug 15819] [Shadow]: Document more use cases for Shadow DOM

[Bug 16009] [Shadow]: Specify how CSS behaves in shadow DOM subtrees

[Bug 16294] [Shadow]: Should ShadowRoot have style or be an Element?

[Bug 17515] [Shadow]: @host and shadow insertion point

[Bug 17516] [Shadow]: Investigate a more thorough set of selectors to traverse shadow DOM

[Bug 17625] Shouldn't ExSel key value be Exsel?

[Bug 18382] [Shadow]: ShadowRoot needs the flag to control @host @-rules in a similar way to the apply-author-styles flag.

[Bug 18435] [Shadow]: Needs consistent way to style the inner element of replaced elements.

[Bug 18511] [Custom]: Things to Consider in the Future

[Bug 18931] D3E should define when compositionupdate event is fired

[Bug 19276] [Shadow]: Consider simplifying addStyleSheet parameters

[Bug 19400] [Shadow]: Specify insertion points in terms of "display:contents"

[Bug 19404] <shadow> nodes should re-project just like <content>

[Bug 19672] [Shadow]: The use of the word "variables" is somewhat confusing.

[Bug 19870] [Imports]: Ensure import resources are loaded relative to location of import definition

[Bug 19891] [Shadow]: Specify how custom pseudo elements are serialized/deserialized

[Bug 20008] allow [Unforgeable] on an interface

[Bug 20017] [Shadow]: Retargeting relatedTarget algorithm prevents events from be fired if a user creates a MouseEvent manually with a relatedTarget which is same to the target.

[Bug 20093] [Shadow]: Clarify how upper bound encapsulation applies to sibling shadowRoots

[Bug 20139] [Shadow]: Scoping constraints should be informative

[Bug 20141] [Shadow]: Ensure that distribution/composition is triggered in all the right places

[Bug 20143] [Shadow]: When you click on dfn, it should show a link to it

[Bug 20144] [Shadow]: Consider adding "private" flag to createShadowRoot

[Bug 20243] [Shadow]: Strengthen boundary between shadow host's document elements and shadow tree nodes

[Bug 20247] [Shadow]: Update constraints around stopping events

[Bug 20260] [Shadow]: ShadowRoot should have olderShadowRoot attribute to get older shadow tree.

[Bug 20279] [Shadow]: Reprojection step needs moar clarity

[Bug 20282] [Shadow]: The old-style getElement* accessors are old and should be gone

[Bug 20295] [Shadow]: Make all Method/Attribute descriptions consistent

[Bug 20304] [Shadow]: pseudo attribute

[Bug 20320] [Shadow]: Unclear how HTML form submission should work

[Bug 20355] [Shadow]: No way to obtain list of Shadow Roots

[Bug 20357] [Shadow]: Wrong argument names of ShadowRoot object methods

[Bug 20488] [Custom]: Need to define what happens when nodes are adopted into or out of documents that have custom element definitions

[Bug 20567] Change [[Prototype]] for concept-node-adopt?

[Bug 20595] [Shadow]: definition of distributed

[Bug 20595] [Shadow]: Distributions need to be defined more clearly

[Bug 20596] [Shadow]: Matching Insertion Points

[Bug 20597] [Shadow]: Matching poorly defined

[Bug 20598] [Shadow]: Hosting Multiple Shadow Trees makes no normative statements

[Bug 20600] [Shadow]: Custom Pseudo-Elements should follow the same convention as custom element names.

[Bug 20604] [Shadow]: Event's relatedTarget must be pre-computed before event dispatch

[Bug 20604] [Shadow]: Make event's relatedTarget part of the set that contains adjusted target

[Bug 20605] [Shadow]: Bring back .host

[Bug 20615] [Shadow]: Clarify 'At the time of event dispatch:"

[Bug 20683] [Imports]: Write HTML Imports spec

[Bug 20704] [Shadow]: 4.5: It is unclear how to define the shadow insertion point.

[Bug 20729] [Shadow]: It is not clear which insertion point is active and which isn't.

[Bug 20957] [Shadow]: Styling elements in shadow trees based on host element

[Bug 20958] [Shadow]: Consider dropping resetStyleInheritance in favor of a CSS property

[Bug 21066] Provide an event path API

[Bug 21067] [Shadow]: Provide an api to insertionParent

[Bug 21083] Proposal key names for Android

[Bug 21115] Define 'Redo' key in the key name list

[Bug 21116] Define 'SingleCandidate' key in the key name list

[Bug 21118] Define power management related keys like 'Power'

[Bug 21119] Define 'ZoomIn' key and 'ZoomOut' key

[Bug 21139] Define key name for Hankaku-Zenkaku key and Katakana-Hiragana key

[Bug 21149] [Shadow]: Shadow DOM-based components could benefit from a way to detect when light DOM contents change

[Bug 21202] [Shadow]: Specify how :host() interacts with the scoped styles

[Bug 21214] [Imports]: Write example for imperative API

[Bug 21226] [Imports]: Components fetching should always use CORS.

[Bug 21229] [Imports]: Imports should fetch and process some external resources

[Bug 21229] [Imports]: would like to be able to load external scripts too

[Bug 21242] [Shadow]: 6.3 @host @-rule should extend the CSS 2.1 grammar 'stylesheet' production

[Bug 21253] [Imports]: Consider changing component location to component identifier

[Bug 21275] [Imports]: Force utf-8

[Bug 21293] [Templates]: EOF processing fails if a <template> in a non-html namespace is on the stack of open elements

[Bug 21295] overload resolution: are DOMString and sequence<T> distinguishable now?

[Bug 21305] [Shadow] Add explanatory rationale for the set of content selectors, and possibly update the spec with selectors from CSS4 Selectors

[Bug 21390] [Shadow]: add support for styling shadowDOM contents based on host element

[Bug 21391] [Shadow]: allow @host rules to match nodes in the host scope not just the host node

[Bug 21399] [Imports]: Specify how URLs of external resources are resolved.

[Bug 21400] [Shadow]: 5.4 Events that are Always Stopped needs clarification

[Bug 21486] [Shadow]: ::distributed should support scope-relative selectors.

[Bug 21499] [Meta]: Web Developers Feedback/Hotlist

[Bug 21591] String constant on NavigatorID is invalid per WebIDL

[Bug 21959] [Shadow]: @host rules should be overridden by selectors in document

[Bug 21966] D3E spec should prohibit browser vendors name original key name

[Bug 21981] Key name definition about "foo[0-9]+"

[Bug 21986] Element.attributes needs to have a named getter

[Bug 21992] Consider adding getInputContext() to SVGElement

[Bug 22018] Consider adding getCompositionAlternatives() in InputMethodContext

[Bug 22028] Consider adding hasComposition() in InputMethodContext

[Bug 22038] [imports]: Dynamic update on <link> attribute should be considered

[Bug 22038] Changing "href" attribute on <link> should trigger re-downloading hyperlink

[Bug 22057] Clarify InputMethodContext's scope in the spec

[Bug 22059] Composition dictionary should be changed

[Bug 22068] [DOM3] Remove Appendix A and replace with references to UI Events spec

[Bug 22080] [Shadow]: Node should expose their scope so that shared state can be scoped to components.

[Bug 22080] [Shadow]: Node should expose there scope so that shared state can be scoped to components.

[Bug 22084] Consistent key names in D3E spec

[Bug 22093] Consider adding candidatewindowshow/update/hide events and getCandidateWindowClientRect()

[Bug 22094] Add 'target' in InputMethodContext

[Bug 22107] [Shadow]: <content> usage in a place where non-flow content is expected

[Bug 22108] [Shadow]: Some editorial issues

[Bug 22128] [Shadow]: Define what "inserted into document" means for elements in shadow tree

[Bug 22132] [imports]: 6 Loading Imports: It is not clear how PARSER and FRAGMENT relate each otehr

[Bug 22141] [Shadow]: Need mechanism to tell if an element in a ShadowRoot has been inserted into the Document

[Bug 22142] [imports]: typos: "a import"

[Bug 22169] [Shadow]: Nit: Update StyleSheetList definition link

[Bug 22194] Clarificaiton of 'enabled' property behavior

[Bug 22196] Clarification of InputMethodContext behavior when an element losts focus.

[Bug 22201] [Shadow]: <shadow> should be used in an example

[Bug 22203] [Shadow]: Define relationships between trees using terms of {child, parent, descendant, ancestor}.

[Bug 22224] [Shadow]: Typo: distrubted => distributed

[Bug 22238] [Shadow]: "part" should be a reflected attribute

[Bug 22238] [Shadow]: pseudo should be a reflected attribute

[Bug 22239] [Shadow]: An exception to applyAuthorStyles should be carved out for custom pseudos

[Bug 22240] [Shadow]: Clarify how nested @host @-rules work

[Bug 22254] [Shadow]: WebIDL code blocks are missing an "idl" classname

[Bug 22255] [Shadow]: Shadow trees should somehow contain base URL information

[Bug 22268] [Shadow]: Consider a <content> selector for "nodes not otherwise distributed"

[Bug 22291] Should indexing form with "" work?

[Bug 22311] [imports]: It is not clear if .import property is null when the resource is not found.

[Bug 22320] Form's supported property names should perhaps not be enumerable

[Bug 22344] [Shadow]: Distribute into <shadow>, project into older shadow root

[Bug 22346] Security: When invoking a method, getter, or setter on an object using the property descriptor of another, we need to do a security check

[Bug 22358] Add a "this is the global" annotation

[Bug 22361] [Shadow]: <title> and <meta> should be considered inert

[Bug 22390] [Shadow]: Support ':host()' pseudo class.

[Bug 22391] Sequence or Array

[Bug 22394] [Shadow]: [Meta] Refactor the Shadow DOM spec

[Bug 22399] [Shadow]: ShadowRoot should have an host property

[Bug 22400] [Templates]: Form-associated elements inside templates should not be associated with forms by the parser

[Bug 22407] [imports]: Consider implications of changing the meaning of <link> with rel=import

[Bug 22411] [Shadow]: Specify the interaction with document.currentScript

[Bug 22412] [Shadow]: Clarify the interaction with XML Namespace

[Bug 22413] [imports]: Imported documents should execute script

[Bug 22426] [Custom]: attributeChangedCallback should provide name of the attribute

[Bug 22426] [Custom]: Set of attribute modifying methods is not exhaustive

[Bug 22433] [Shadow]: Supports a <shadow> reprojection

[Bug 22443] [Shadow]: Form elements crossing shadow boundary

[Bug 22459] [Custom]: Consider explicitly emptying callback queue in more cases

[Bug 22460] [Shadow]: Change ::distributed to ::content

[Bug 22461] [Shadow]: Change custom pseudo elements to match via ::part(<part name>)

[Bug 22462] [Shadow]: Consider adding an applyAuthorHostStyles flag

[Bug 22466] [Custom]: Certain documents should not share registration contexts

[Bug 22485] [Custom]: registration context is defined oddly since Window of a document may change

[Bug 22512] "Copy the following, depending on the type of node"

[Bug 22513] "Run any cloning steps defined for node in other..."

[Bug 22514] "optionally with a document ownerDocument"

[Bug 22515] Consider moving getElementBy* to ParentNode

[Bug 22521] [Custom]: Element constructor algorithm bleeds definitions across registration contexts

[Bug 22522] WebIDL, error handling, and promises

[Bug 22537] documentation typo

[Bug 22537] New: documentation typo

[Bug 22538] documentation typo

[Bug 22538] New: documentation typo

[Bug 22539] [Shadow]: Add support for external stylesheets using link rel="stylesheet"

[Bug 22539] New: [Shadow]: Add support for external stylesheets using link rel="stylesheet"

[Bug 22540] Fire event when database connection is closed without explicit close() call

[Bug 22540] New: Fire event when database connection is closed without explicit close() call

[Bug 22560] [imports]: Recursion?

[Bug 22560] New: [imports]: Recursion?

[Bug 22564] [Custom]: Rename readyCallback to createdCallback

[Bug 22564] New: [Custom]: Rename readyCallback to createdCallback

[Bug 22565] [Custom]: rename inserted/removedCallback to entered/leftDocumentCallback

[Bug 22565] New: [Custom]: rename inserted/removedCallback to entered/leftDocumentCallback

[Bug 22566] [Custom]: Element upgrade algorithm set prototype right before createdCallback is called

[Bug 22566] New: [Custom]: Element upgrade algorithm set prototype right before createdCallback is called

[Bug 22569] MouseEvent should have DOMString pseudoElement property like TransitionEvent

[Bug 22569] New: MouseEvent should have DOMString pseudoElement property like TransitionEvent

[Bug 22589] document.register() signature in intro doesn't match spec

[Bug 22589] New: document.register() signature in intro doesn't match spec

[Bug 22600] Need a way to make navigator.plugins supported named properties not enumerable

[Bug 22600] New: Need a way to make navigator.plugins supported named properties not enumerable

[Bug 22602] New: Anchor for 6.4.1. The slice method is broken

[Bug 22625] New: "If x < 253 or x > 253, then throw a TypeError."

[Bug 22626] New: File API needs to add Blob URL store and revocation list for use with URL parsing

[Bug 22636] any? is invalid IDL

[Bug 22636] New: any? is invalid IDL

[Bug 22637] New: spec lacks a link to file bugs

[Bug 22637] spec lacks a link to file bugs

[Bug 22641] New: Normatively specify the order in which mouse events should fire

[Bug 22641] Normatively specify the order in which mouse events should fire

[Bug 22644] "FormData" and workers

[Bug 22644] New: "FormData" and workers

[Bug 22646] So if we want to say on a per-object basis whether it ought to be exposed to workers (which I think is useful) lets introduce "exposed to document environments", "exposed to worker environments", and [...]

[Bug 22650] "conditions udner which" misspelling

[Bug 22650] New: "conditions udner which" misspelling

[Bug 22665] New: Wrong example for [TreatNonCallableAsNull]

[Bug 22691] New: Remove ByteString from WebIDL

[Bug 22691] Remove ByteString from WebIDL

[Bug 22711] Add a .empty method to the ParentNode (or the Node?) interface

[Bug 22711] New: Add a .empty method to the ParentNode (or the Node?) interface

[Bug 22715] [Shadow]: [Meta] New features and improvements

[Bug 22715] New: [Shadow]: [Meta] New features and improvements

[Bug 22716] [Shadow]: [Meta] Cleanup, refactoring, and polish

[Bug 22716] New: [Shadow]: [Meta] Cleanup, refactoring, and polish

[Bug 22720] Components should use "lifetime events" rather than "lifetime callbacks"

[Bug 22720] New: Components should use "lifetime events" rather than "lifetime callbacks"

[Bug 22745] New: [Custom]: Use case for registering a type extension of an unknown element

[Bug 22750] New: What's the good key name for "Eisu" (英数) key of JIS keyboard for Mac?

[Bug 22750] What's the good key name for "Eisu" (英数) key of JIS keyboard for Mac?

[Bug 22752] [imports]: Imports should respect CSP

[Bug 22752] New: [imports]: Imports should respect CSP

[Bug 22754] " width:100%; height:100%;"

[Bug 22754] New: " width:100%; height:100%;"

[Bug 22756] "Let listeners be a static list of the event lis..."

[Bug 22756] New: "Let listeners be a static list of the event lis..."

[Bug 22757] "If listener's callback is a Function object, it..."

[Bug 22757] New: "If listener's callback is a Function object, it..."

[Bug 22758] "When set to true, the capture argument ensures ..."

[Bug 22758] New: "When set to true, the capture argument ensures ..."

[Bug 22759] It is not clear what happens to the existing transient observers when MutationObserver.observe is called

[Bug 22759] New: It is not clear what happens to the existing transient observers when MutationObserver.observe is called

[Bug 22766] document.width, document.height, etc available for cross-platform

[Bug 22766] New: document.width, document.height, etc available for cross-platform

[Bug 22772] New: width, height, top, left attributes or properties that always work

[Bug 22772] width, height, top, left attributes or properties that always work

[Bug 22788] [Shadow]: Clarify apply-author-styles when styling elements in shadow trees based on host element

[Bug 22788] New: [Shadow]: Clarify apply-author-styles when styling elements in shadow trees based on host element

[Bug 22790] [Shadow]: Rename 'insertion points' to 'distribution points'.

[Bug 22790] New: [Shadow]: Rename 'insertion points' to 'distribution points'.

[Bug 22793] [Shadow]: Clarify the event path should be trimmed when target and relatedTarget are the same at a node.

[Bug 22793] New: [Shadow]: Clarify the event path should be trimmed when target and relatedTarget are the same at a node.

[Bug 22798] [Shadow]: Need to rewrite the focus navigation section.

[Bug 22798] New: [Shadow]: Need to rewrite the focus navigation section.

[Bug 22799] [Shadow]: Need to rewrite the activeElement section.

[Bug 22799] New: [Shadow]: Need to rewrite the activeElement section.

[Bug 22806] New: Why special case Date and RegExp in #es-sequence

[Bug 22806] Why special case Date and RegExp in #es-sequence

[Bug 22808] New: Throw if you object is constructed without new

[Bug 22808] Throw if object is constructed without new

[Bug 22809] 'error' progress event is never fired

[Bug 22809] New: 'error' progress event is never fired

[Bug 22810] New: [Shadow]: Step 1.2 in the distribution resolution algorithm does not seem needed

[Bug 22811] New: [Shadow]: Buncha' typos in the spec

[Bug 22813] New: [Shadow]: Broken links from missing hash

[Bug 22824] New: Remove Date from WebIDL

[Bug 22824] Remove Date from WebIDL

[Bug 22826] [Shadow]: Clarify how getComputedStyle with unprojected elements works

[Bug 22826] New: [Shadow]: Clarify how getComputedStyle with unprojected elements works

[Bug 22827] New: [Custom]: Confusing condition on documents and registration contexts in constructor invocation

[Bug 22829] [Shadow]: clarify ::distributed (::content) syntax

[Bug 22829] New: [Shadow]: clarify ::distributed (::content) syntax

[Bug 22833] New: [Custom]: Declarative syntax does not account for out-of-order declarations

[Bug 22834] DOM_KEY_LOCATION_MOBILE and _JOYSTICK are no longer needed

[Bug 22834] DOM_KEY_LOCATION_MOBILE and _JOYSTICK need more

[Bug 22834] New: DOM_KEY_LOCATION_MOBILE and _JOYSTICK need more

[Bug 22836] Missing First Principle in overall Design

[Bug 22836] New: Missing First Principle in overall Design

[Bug 22840] JSON response and user defined JSON.parse

[Bug 22840] New: JSON response and user defined JSON.parse

[Bug 22842] New: Should keyboard events fire during a composition session?

[Bug 22842] Should keyboard events fire during a composition session?

[Bug 22845] New: Consider moving the overload resolution algorithm into its own section

[Bug 22847] Add dummy captureEvents/releaseEvents to document/window

[Bug 22847] Add dummy captureEvents/releaseEvents/routeEvent to document/window

Last message date: Wednesday, 31 July 2013 22:42:14 UTC