Re: [RequestAnimationFrame] Callback argument should be a callback interface, not just a callback

On 2/22/12 9:59 AM, Anne van Kesteren wrote:
> We've had a long discussion on this and decided to simplify callbacks.

Hmm.  I must have missed this discussion.  I don't see how this 
simplifies callbacks at all, for _authors_...  what am I missing?


P.S. This is of course trivial to implement on the Gecko side for me: 
just throw if the passed-in object is not a function and otherwise do 
exactly what I'm doing now.  Again, it seems like all that's doing is 
taking flexibility away from authors.

Received on Wednesday, 22 February 2012 15:25:05 UTC