RE: [Resource Timing] User feedback and a modified proposal

We agree on these points:
> MUST use a "-<vendor>-" prefix to any custom attributes on 
> PerformanceTiming MUST use the same clock system

I can take an action to update the spec here. Maybe the following text?

Section 4.6 Vendor Prefixes

Vendor-specific proprietary user agent extensions to this specification are strongly discouraged. If such extensions are nonetheless needed, e.g. for experimental purposes, vendors are strongly urged to use the following extension mechanisms:

If the extension to be added is an INITIATOR type, the INITIATOR type must:
- Follow this naming convention pattern: INITIATOR_[VENDORPREFIX]_[TYPE], where VENDORPREFIX is a name that identifies the vendor.
- Have a value in the range of 100 to 200

If the extension is a new timing attribute, it must:
- Follow this naming convention: [vendorPrefix]TimeName, where VENDORPREFIX is a name that identifies the vendor. 
- Use the same clock as "time" is defined in Section 3 Terminology.

> that the ResourceTimingBufferSize SHOULD be increased appropriately

The buffer size is the number of resources captured by default, not the size of the elements themselves.  How would the buffersize be effected by vendor extensions?

> and that looping over the attributes on PerformanceTiming MUST list custom attributes last.

I'm not quite sure of the benefits of this - can you explain?


Received on Saturday, 28 May 2011 00:07:45 UTC