Re: [RequestAnimationFrame] cancelRequestAnimationFrame is an odd name

On 12/8/11 5:22 PM, James Robinson wrote:
> Thanks for the feedback.  I've pushed
> to the editor's draft to
> rename from cancelRequestAnimationFrame() to cancelAnimationFrame(). You
> can see the version of the spec with this change here:
>   I expect to update the WebKit vendor-prefixed implementation soon to
> reflect this change.

I suspect you won't be able to, actually, due to web compat issues. 
Certainly Gecko won't be able to without keeping the old name as an 
alias; at least Google maps looks for mozCancelRequestAnimationFrame and 
breaks if that's not present.

So when we unprefix we'll unprefix to cancelAnimationFrame, but the 
prefixed version might stay as-is for now or grow the other alongside it.


Received on Thursday, 8 December 2011 23:16:57 UTC