[NavigationTiming] Move window.performance to navigator.performance


I'm a bit concerned about

interface Window {
   readonly attribute Performance performance;

This adds a new property 'performance' to the global scope. I think there  
may be pages out there that already use that property for other things --  
script variables or <div id="performance"> or <a name="performance"> or  
<form onsubmit="return validate(performance.value)"><input  
name="performance">, and so forth.


To avoid polluting the global scope with a common name, potentially  
breaking scripts out there, I suggest we move the attribute to the  
Navigator interface.


To follow the convention around Navigator in HTML5 I guess it could look  
something like:

[Supplemental, NoInterfaceObject]
interface NavigatorPerformance {
   readonly attribute Performance performance;
Navigator implements NavigatorPerformance;

Simon Pieters
Opera Software

Received on Tuesday, 23 November 2010 10:10:44 UTC