W3C home > Mailing lists > Public > public-web-notification@w3.org > March 2012

Re: Rename replaceID attribute (was Feedback from Safari on Web Notifications)

From: Jon Lee <jonlee@apple.com>
Date: Tue, 13 Mar 2012 09:58:37 -0700
Cc: public-web-notification@w3.org, Maciej Stachowiak <mjs@apple.com>
Message-id: <66E71B1B-3625-41B9-9F0E-9785745C7A6D@apple.com>
To: John Gregg <johnnyg@google.com>

On Mar 13, 2012, at 9:34 AM, John Gregg wrote:

> On Mon, Mar 12, 2012 at 1:24 AM, Jon Lee <jonlee@apple.com> wrote:
> Hello everyone,
> The initial discussion based on Safari's feedback looked at one issue, but hasn't looked at the rest. To avoid confusion, I'm splitting out the other outstanding 3 points into separate threads.
> To recap, the original proposal was to replace setReplaceId() with an attribute "id". John Gregg felt "id" suggested uniqueness, which is not true. I felt that "id" was the problem then, and suggested using "tag" to imply this common relationship between notifications. Thoughts?
> Jon
> No objection to changing the name "replaceID" to "tag", but I thought part of your proposal was also concerning the specified behavior of the "tag", i.e., specifying that the UA either in-place update or close and re-open the notification with the same (origin, tag).  
> I would prefer to keep that specified behavior.
No, I originally might have thought that on a separate thread, but now agree with you about the expected behavior, especially since it is specified in the replace algorithm. I just feel, currently, that the current name, while descriptive, is awkward.

And just to be explicit, I assume we all agree to replace setReplaceId() with an attribute.


Received on Tuesday, 13 March 2012 17:00:33 UTC

This archive was generated by hypermail 2.4.0 : Thursday, 1 July 2021 16:05:28 UTC