Re: Rename replaceID attribute (was Feedback from Safari on Web Notifications)

Hey John,

Same behavior as currently spec wfm.

I do not mind just using the word 'id' or 'tag'.


On Mar 13, 2012, at 9:34 AM, John Gregg wrote:

> On Mon, Mar 12, 2012 at 1:24 AM, Jon Lee <> wrote:
> Hello everyone,
> The initial discussion based on Safari's feedback looked at one issue, but hasn't looked at the rest. To avoid confusion, I'm splitting out the other outstanding 3 points into separate threads.
> To recap, the original proposal was to replace setReplaceId() with an attribute "id". John Gregg felt "id" suggested uniqueness, which is not true. I felt that "id" was the problem then, and suggested using "tag" to imply this common relationship between notifications. Thoughts?
> Jon
> No objection to changing the name "replaceID" to "tag", but I thought part of your proposal was also concerning the specified behavior of the "tag", i.e., specifying that the UA either in-place update or close and re-open the notification with the same (origin, tag).  
> I would prefer to keep that specified behavior.

Received on Tuesday, 13 March 2012 16:47:21 UTC