W3C home > Mailing lists > Public > public-web-bluetooth@w3.org > May 2016

Re: [QUESTION] server.getPrimaryService() doesn't work

From: Jeffrey Yasskin <jyasskin@google.com>
Date: Fri, 20 May 2016 09:21:05 -0700
Message-ID: <CANh-dX=5AOrf+evGGrV-rBVdhxab=GOPBoMvwxfLJApxN4bHnQ@mail.gmail.com>
To: 別府多久哉 <tky.bpp.ml@gmail.com>
Cc: Web Bluetooth in Chromium <web-bluetooth@chromium.org>
Please ask questions about Chrome's implementation on
web-bluetooth@chromium.org. public-web-bluetooth is for comments about the
specification.

I think we broke ChromeOS on the dev channel when we upgraded to BlueZ
5.39: https://crbug.com/606011. It should be fixed in the dev channel
release next week, or on Android or the ChromeOS beta channel.

Sorry for the trouble.
Jeffrey

On Fri, May 20, 2016 at 8:46 AM, 別府多久哉 <tky.bpp.ml@gmail.com> wrote:

> Hi, everyone.
>
> I have a question, but I have no idea. Could you help me?
> I tried to call gerPrimaryService() on Chromebook in this page :
> https://googlechrome.github.io/samples/web-bluetooth/battery-level.html
> , and I used PLAYBULB Candle.
> But it stops after display this message "Getting Battery Service..."
> with no errors.
> It worked collectly before today, but it doesn't work suddenly.
> Also I have tried with my own application and hardware, but it doesn't
> work either.
> I don't know the cause of this issue, my chromebook or hardware?
> Do you have any idea for this?
>
> This is my develop environment:
>   Chrome OS : version 52.0.2727.0 dev(64-bit)
>   Platform  : 8302.0.0 (Official Build) dev-channnel auron_yuna
>   Firmware Google_Auron_yuna.6301.59.8
>
> Best regards,
> Takuya
>
>
>
Received on Friday, 20 May 2016 16:21:53 UTC

This archive was generated by hypermail 2.3.1 : Friday, 20 May 2016 16:21:54 UTC