W3C home > Mailing lists > Public > public-web-bluetooth@w3.org > May 2016

[QUESTION] server.getPrimaryService() doesn't work

From: 別府多久哉 <tky.bpp.ml@gmail.com>
Date: Fri, 20 May 2016 17:46:25 +0200
Message-ID: <CAPzB5mW2yVH889jZgtXekhXjWutVcSV-uyxP1_0zFpE+o5wibw@mail.gmail.com>
To: public-web-bluetooth@w3.org
Hi, everyone.

I have a question, but I have no idea. Could you help me?
I tried to call gerPrimaryService() on Chromebook in this page :
https://googlechrome.github.io/samples/web-bluetooth/battery-level.html
, and I used PLAYBULB Candle.
But it stops after display this message "Getting Battery Service..."
with no errors.
It worked collectly before today, but it doesn't work suddenly.
Also I have tried with my own application and hardware, but it doesn't
work either.
I don't know the cause of this issue, my chromebook or hardware?
Do you have any idea for this?

This is my develop environment:
  Chrome OS : version 52.0.2727.0 dev(64-bit)
  Platform  : 8302.0.0 (Official Build) dev-channnel auron_yuna
  Firmware Google_Auron_yuna.6301.59.8

Best regards,
Takuya
Received on Friday, 20 May 2016 16:04:22 UTC

This archive was generated by hypermail 2.3.1 : Friday, 20 May 2016 16:04:22 UTC