W3C home > Mailing lists > Public > public-script-coord@w3.org > July to September 2013

Re: URLQuery / FormData

From: Jonas Sicking <jonas@sicking.cc>
Date: Mon, 9 Sep 2013 22:59:41 +0200
Message-ID: <CA+c2ei8z5WUxwXNNcHXn4LOB9pT8A_pa+0LEt0E=+ja_uj6ruw@mail.gmail.com>
To: Anne van Kesteren <annevk@annevk.nl>
Cc: "public-script-coord@w3.org" <public-script-coord@w3.org>
On Mon, Sep 9, 2013 at 1:30 PM, Anne van Kesteren <annevk@annevk.nl> wrote:
> * get(name) -- always returns an array, with ES6 destructering this
> should be fine

This seems like optimizing for the rare case.

> I'll leave out set() for now.

This also seems like optimizing for the rare case.

> Since it's a list I don't think item count should be called size, but
> rather length. However, maybe we don't need that for now either.

Leaving it out seems fine for now. I don't know of any particularly
important use cases for URLs that needs getting the size.

/ Jonas
Received on Monday, 9 September 2013 21:00:39 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:18 UTC