W3C home > Mailing lists > Public > public-rdf-wg@w3.org > October 2013

RE: (proposal) was Re: defn of Named Graph

From: Markus Lanthaler <markus.lanthaler@gmx.net>
Date: Thu, 3 Oct 2013 17:01:37 +0200
To: <public-rdf-wg@w3.org>
Message-ID: <011501cec049$76378a20$62a69e60$@lanthaler@gmx.net>
On Friday, September 27, 2013 6:35 PM, Pat Hayes wrote:
> Let me (only just now surfacing from a few days off-web) suggest:
> (6) Keep the idea but modify the terminology. As Andy points out,
> "Named Graph" already has too much baggage (and in any case is weirdly
> misleading in two ways). But we already have some useful terminology in
> the LC specs: Concepts 1.1 defines "RDF Source" as a nameable thingie
> that emits or embodies RDF (and might be labile). So lets take this and
> run with it, and talk about "fixed RDF Source" as a non-labile species
> of RDF source, and say that the graph name denotes that. Or even just
> forget about the "fixed" part:
> "3. We note that RDF Datasets can be used to state which triples are in
> certain RDF Sources.
> 4. We define a class (eg rdf:BasicDataset) of the Datasets which have
> those semantics."
> This avoids all the issues that Andy raises, and has the advantage that
> it has a very smooth segway into datase... sorry, things like datasets
> but which are allowed to be updated.

+1 but...

... as I've just re-read the definition of RDF source in Concepts, it
appears that its definition is wrong (or at least inconsistent):

   We informally use the term RDF source to refer to a persistent yet
   source or container of RDF graphs. An RDF source is a resource that may
   said to have a state that can change over time. A snapshot of the state
   be expressed as an RDF graph

So a RDF source may return *multiple* RDF graphs, i.e., a dataset but at the
same time it is possible to express a snapshot as a *single* RDF *graph*.

Thus, we should either define something like a "RDF graph source" or say
that a snapshot of a RDF source can be expressed as a RDF dataset.

If we are going to use this reuse terminology, I think we should also name
the classes accordingly. Something like rdf:RdfGraphSource and potentially
also something like rdf:TripleSource or just rdf:RdfSource.

Markus Lanthaler
Received on Thursday, 3 October 2013 15:02:10 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:04:33 UTC