W3C home > Mailing lists > Public > public-qt-comments@w3.org > June 2016

[Bug 29612] [FO31] Function argument naming

From: <bugzilla@jessica.w3.org>
Date: Mon, 06 Jun 2016 15:21:03 +0000
To: public-qt-comments@w3.org
Message-ID: <bug-29612-523-lw3RbtR9qX@http.www.w3.org/Bugs/Public/>

Michael Kay <mike@saxonica.com> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED

--- Comment #2 from Michael Kay <mike@saxonica.com> ---
I have changed map:keys(), map:size(), and map:for-each() to use $map as the
name of the first argument.

I have changed map:for-each(), array:for-each(), fn:for-each(), and
fn:for-each-pair() to use $action as the name of the function argument.

Note: I'm not sure these changes at this stage are really a good idea. There is
a grave danger of introducing unnecessary errors, and I'm not at all convinced
we should be encouraging readers to think of the argument names as being in any
way significant.

You are receiving this mail because:
You are the QA Contact for the bug.
Received on Monday, 6 June 2016 15:21:07 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:58:00 UTC