W3C home > Mailing lists > Public > public-qt-comments@w3.org > August 2014

[Bug 26559] New: Maps and Arrays: Analogies

From: <bugzilla@jessica.w3.org>
Date: Tue, 12 Aug 2014 15:21:43 +0000
To: public-qt-comments@w3.org
Message-ID: <bug-26559-523@http.www.w3.org/Bugs/Public/>

            Bug ID: 26559
           Summary: Maps and Arrays: Analogies
           Product: XPath / XQuery / XSLT
           Version: Working drafts
          Hardware: PC
                OS: Windows NT
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XQuery 3.1
          Assignee: jonathan.robie@gmail.com
          Reporter: christian.gruen@gmail.com
        QA Contact: public-qt-comments@w3.org

I was asked why some of the new map and array functions have been named so
differently although they do similar things, and why there is some redundant
functionality. Here are the suggestions we came up with:

* array:size vs. (no map:size anymore): it would be great if "map:size" was
readded to the spec; count(map:keys()) is not very intuitive, at least to me,
and it feels like a burden to loop through data if you simply want to know the
number of entries.

* map:for-each-entry, array:for-each-member: we could simplify the names to
map:for-each and array:for-each, because the other functions are not named
"array:filter-members" etc. either.

* map:merge vs. array:join: although different things may happen under the
hood, they could share the same name. "map:join" sounds like an intelligible
alternative to me.

* map:get vs. (no array:get): maybe we can get rid of this function, or (if it
is required for some reason) additionally provide "array:get"?

* map:entry: maybe we can give up this one, too?

You are receiving this mail because:
You are the QA Contact for the bug.
Received on Tuesday, 12 August 2014 15:21:47 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:57:47 UTC