W3C home > Mailing lists > Public > public-qt-comments@w3.org > November 2011

[Bug 14930] New: [XQ30] Missing error condition for default namespace declarations

From: <bugzilla@jessica.w3.org>
Date: Fri, 25 Nov 2011 09:30:10 +0000
To: public-qt-comments@w3.org
Message-ID: <bug-14930-523@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=14930

           Summary: [XQ30] Missing error condition for default namespace
                    declarations
           Product: XPath / XQuery / XSLT
           Version: Recommendation
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: minor
          Priority: P2
         Component: XQuery 3.0
        AssignedTo: jonathan.robie@gmail.com
        ReportedBy: mike@saxonica.com
         QAContact: public-qt-comments@w3.org


The rule in 4.13: "The namespace URI specified in a namespace declaration must
not be http://www.w3.org/XML/1998/namespace or http://www.w3.org/2000/xmlns/
[err:XQST0070]." should apply to default namespace declarations as well as
namespace declarations.

(Note that according to the definition in 4.13, a "default namespace
declaration" is not a "namespace declaration", and the spec is scrupulous in
making this distinction).

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 25 November 2011 09:30:15 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:57:36 UTC