W3C home > Mailing lists > Public > public-qt-comments@w3.org > November 2009

[Bug 5857] [XSLT 2.0] A problem with namespace inheritance

From: <bugzilla@wiggum.w3.org>
Date: Fri, 13 Nov 2009 15:38:01 +0000
To: public-qt-comments@w3.org
Message-Id: <E1N8yDp-0000pc-6g@wiggum.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=5857


Michael Kay <mike@saxonica.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED




--- Comment #6 from Michael Kay <mike@saxonica.com>  2009-11-13 15:38:00 ---
At its telcon on 12 Nov 2009 the WG accepted the resolution given by the second
version of proposed text in comment #3, namely:

<quote>
If the newly constructed node is an element node, and if namespaces are
inherited, then each named (that is, non-default) namespace node of the newly
constructed element (including any produced as a result of the namespace fixup
process) is copied to each descendant element of the newly constructed element,
unless that element or an intermediate element already has a namespace node
with the same name.
</quote>

This will be the subject of erratum XT.E37 (drafted)


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 13 November 2009 15:38:02 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:57:29 UTC