W3C home > Mailing lists > Public > public-qt-comments@w3.org > September 2005

[Bug 2262] [xqueryx] 0-ary function arguments

From: <bugzilla@wiggum.w3.org>
Date: Wed, 28 Sep 2005 14:11:19 +0000
To: public-qt-comments@w3.org
Cc:
Message-Id: <E1EKceV-0005Q5-Br@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=2262





------- Additional Comments From jim.melton@acm.org  2005-09-28 14:11 -------
The XML Query WG discussed this comment, including your pushback.  We observe
that there exist other examples in XQueryX where it is possible to represent the
same XQuery syntax both as the absence of an element and as the presence of an
element with no content.  (See mainModule and prolog, for example.) 

Because of those other examples, the fact that neither they nor this example are
actually broken, and the need to expend resources fixing more serious problems,
the WG declines to make the additional restriction that you have suggested. 

Please let us know if you are able to accept this resolution of your issue, by
adding a comment to the issue record and changing the Status of the issue to
Closed. Or, if you do not agree with this resolution, please add a comment
explaining why.  If you wish to appeal the WG's decision to the Director, then
also change the Status of the record to Reopened. If you wish to record your
dissent, but do not wish to appeal the decision to the Director, then change the
Status of the record to Closed. If we do not hear from you in the next two
weeks, we will assume you agree with the WG decision.
Received on Wednesday, 28 September 2005 14:12:39 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:57:08 UTC