W3C home > Mailing lists > Public > public-qt-comments@w3.org > September 2005

[Bug 2278] XML 1.1 implementations SHOULD support 1.0-only mode

From: <bugzilla@wiggum.w3.org>
Date: Wed, 21 Sep 2005 16:22:44 +0000
To: public-qt-comments@w3.org
Cc:
Message-Id: <E1EI7Mq-0005E0-JO@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=2278

           Summary: XML 1.1 implementations SHOULD support 1.0-only mode
           Product: XPath / XQuery / XSLT
           Version: Last Call drafts
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XQuery
        AssignedTo: chamberl@almaden.ibm.com
        ReportedBy: cowan@ccil.org
         QAContact: public-qt-comments@w3.org


The Note in section A.2, "Implementations that support the full [XML 1.1]
character set may wish, for purposes of interoperability, to provide a mode that
follows only the [XML 1.0] and [XML Names] lexical rules" should be strengthened
to say "SHOULD provide a mode".  This improves alignment with the XML 1.1
Recommendation, which says that XML 1.1 parsers SHOULD be able to deal with XML
1.0 documents.

Similar comments should be added to XQuery 1.0, XPath 2.0, and XSLT 2.0.

I'm reporting the consensus of the XML Core WG here.
Received on Wednesday, 21 September 2005 16:24:56 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:57:08 UTC