Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

On Mon, May 14, 2012 at 7:29 PM, Timothy Lebo <> wrote:
> wasQuoteOf: we started with this definition, and moved away because it was
> confusing.
> Overall, I think it loses clarity (hence my suggestion to move away from it
> months back).

What was the confusion about ':e2 wasQuoteFrom :e1'?

:e2 is a *quote*, even if we don't have a prov:Quote subclass. This
should make it much clearer than (slightly more grammatically correct,
but directionally confusing) wasQuotedFrom, because you know that the
domain has to be the actual quote, not just something that contains
the quote. The direction is also clear, the quote is :e2 on the left,
the source and possibly bigger entity is :e1 on the right.

> wasAQuoteFrom: there was no consensus because "if it was a quote, then what
> is it now"?

OK, what about 'quoteFrom' then. No verb - but if you insist we can't
use past tense on this one, what do we do?

The argument 'what is it now' could be applied to the other
properties, is that thing no longer derived from B? Is it no longer
generated by X?  Does it no longer have that original source?  We
don't know what it has 'now' - that is undefined - provenance is about
the past, and in the past it was a quote from X.

Stian Soiland-Reyes, myGrid team
School of Computer Science
The University of Manchester

Received on Tuesday, 15 May 2012 09:09:13 UTC