Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

Hi Daniel,

I don't believe there was consensus to change the name of the relation 
as you suggested.
We also have removed agents from this definition. Definition of 
quote/original attributes
are as follows:

quote: an identifier (e2) for the entity that represents the quote (the 
partial copy);
original: an identifier (e1) for the original entity being quoted;

Can we close this issue?

On 04/19/2012 11:28 AM, Provenance Working Group Issue Tracker wrote:
> PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]
> Raised by: Daniel Garijo
> On product: prov-dm
> Currently, the DM says:
> A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,attrs) in PROV-ASN, contains:
>      quote: an identifier e2, identifying an entity record that represents the quote;
>      quoted: an identifier e1, identifying an entity record representing what is being quoted;
> ...
> However, if we say that e2 wasQuotedFrom e1 it may look like entity e1 is the one quoting e2 (since we are saying that e2 was quoted).
> I think it would be more clear if we rename the property with e2 wasQuoteOf e1, or e2 hadQuoteFrom e1.
> Thoughts?
> Thanks,
> Daniel

Professor Luc Moreau
Electronics and Computer Science   tel:   +44 23 8059 4487
University of Southampton          fax:   +44 23 8059 2865
Southampton SO17 1BJ               email:
United Kingdom           

Received on Tuesday, 8 May 2012 14:11:09 UTC