W3C home > Mailing lists > Public > public-prov-wg@w3.org > April 2012

PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

From: Provenance Working Group Issue Tracker <sysbot+tracker@w3.org>
Date: Thu, 19 Apr 2012 10:28:04 +0000
Message-Id: <E1SKoaq-0008MI-KQ@nelson.w3.org>
To: public-prov-wg@w3.org
PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]


Raised by: Daniel Garijo
On product: prov-dm

Currently, the DM says:
A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,attrs) in PROV-ASN, contains:
    quote: an identifier e2, identifying an entity record that represents the quote;
    quoted: an identifier e1, identifying an entity record representing what is being quoted; 

However, if we say that e2 wasQuotedFrom e1 it may look like entity e1 is the one quoting e2 (since we are saying that e2 was quoted).

I think it would be more clear if we rename the property with e2 wasQuoteOf e1, or e2 hadQuoteFrom e1. 

Received on Thursday, 19 April 2012 10:28:12 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:51:11 UTC