Re: distinguishing between 'description URLs' and 'interface URLs'

On Wed, May 9, 2012 at 1:55 PM, Marcos Caceres <w3c@marcosc.com> wrote:
> Just to handle the simple case, is it possible to change the data to make it more descriptive (then you don't need to deal so much with the URI semantics)? Like:
>
> <person
>   email="some@email.com"
>   description="http://about.me/description"
> />
>
> Or is that something you are already doing?

So say 'description' instead of 'description-URI'? that wouldn't work.
'description' already means 'description'. :) If you make a method
called setDescription(string) and then make its behaviour to be
setDescriptionUri(string) then you've made a misnomer.

in the case of email this is less obvious, because we (wrongly)
already often use 'email' to mean 'email address'. although sometimes
we also use 'email' to mean 'email message'. but the real meaning of
'email' is 'email, the medium'. so in terms of variable naming, i
would say what you proposed there is pretty close, but no cigar. i
would instead do:


<person
   emailAddress="some@email.com"
   descriptionUri="http://about.me/description"
/>

just to avoid confusion. as a programmer you can't be careful and
precise enough when naming your variables IMO.

Received on Wednesday, 9 May 2012 13:50:18 UTC