Re: Call for vote on structure - Re: Please assign yourself on GH

On Wednesday, January 9, 2013 at 9:34 PM, François REMY wrote:

> If we want the code to be useful, we need not to use boxing. However, I'm fine with AMD. My preferred solution would be something like a namespace called WebIDL.Converters where we would put a list of function to be used as (unboxed) converters. When we need a conversion to a type, we would check if there's a converter for the type or we would use instanceof instead.

This ends up looking more or less identical to what we have now, excluding boxes. My model is basically identical in that: WebIDL.Boolean.converter returns you the converter, while in your model it's WebIDL.Converters.Boolean.

I'm biased, in that I like having the types to interface with (because they are wrapped and, IMO, map to the abstract WebIDL types). That is, I like the idea that I can work/play with:

var thingy = new WebIDL.Whatever(value);  

Another option is that WebIDL gains a way of adding types so that then the .Converters gets exposed. That way, we get the best of both worlds?

Received on Wednesday, 9 January 2013 23:49:18 UTC