Re: New Editor's Draft of MediaStream Image Capture

In the PhotoSettings WebIDL, I think autoExposureMode should be declared
ExposureModeEnum instead of 'any'.

ExposureModeEnum should just be called ExposureMode.

The duplication between PhotoSettings and PhotoOptions is unfortunate.
Especially because ImageCapture.setOptions takes a PhotoSettings not a
PhotoOptions! I think it would be simpler to get rid of PhotoOptions and
make all its attributes be direct (read/write) attributes of the
ImageCapture object. Then PhotoSettings would just be a way to expose the
capabilities of the device, so we could rename it to PhotoCapabilities and
simplify it a bit.

Personally I'd just eliminate PhotoCapabilities too and add readonly
attributes directly to MediaCapture like brightnessMin/brightnessMax. Or,
for values (like brightness) that aren't on a specified scale anyway,
simply say that 0 is min brightness and 1 is max brightness.

There's a typo in the PhotoSettings and PhotoOptions WebIDL: "constrast".

Shouldn't PhotoSettings contain "zoom"?

The difference between grabFrame and takePhoto is quite subtle. Would it
make sense to only have one method and event handler, and add an option
that specifies whether to just grab a frame or go to the effort of taking a
still shot?

Rob
-- 
oIo otoeololo oyooouo otohoaoto oaonoyooonoeo owohooo oioso oaonogoroyo
owoiotoho oao oboroootohoeoro oooro osoiosotoeoro owoiololo oboeo
osouobojoeocoto otooo ojouodogomoeonoto.o oAogoaoiono,o oaonoyooonoeo
owohooo
osoaoyoso otooo oao oboroootohoeoro oooro osoiosotoeoro,o o‘oRoaocoao,o’o
oioso
oaonosowoeoroaoboloeo otooo otohoeo ocooouoroto.o oAonodo oaonoyooonoeo
owohooo
osoaoyoso,o o‘oYooouo ofooooolo!o’o owoiololo oboeo oiono odoaonogoeoro
ooofo
otohoeo ofoioroeo ooofo ohoeololo.

Received on Friday, 5 September 2014 00:28:32 UTC