W3C home > Mailing lists > Public > public-media-capture@w3.org > October 2013

Re: [Bug 23263] New: Add output device enumeration to GetSources

From: Adam Bergkvist <adam.bergkvist@ericsson.com>
Date: Fri, 4 Oct 2013 13:45:49 +0200
Message-ID: <524EAA6D.6050106@ericsson.com>
To: <bugzilla@jessica.w3.org>
CC: <public-media-capture@w3.org>
On 2013-09-17 15:55, bugzilla@jessica.w3.org wrote:
> https://www.w3.org/Bugs/Public/show_bug.cgi?id=23263
>
>              Bug ID: 23263
>             Summary: Add output device enumeration to GetSources
>             Product: WebRTC Working Group
>             Version: unspecified
>            Hardware: All
>                  OS: All
>              Status: NEW
>            Severity: normal
>            Priority: P2
>           Component: Media Capture and Streams
>            Assignee: public-media-capture@w3.org
>            Reporter: harald@alvestrand.no
>                  CC: public-media-capture@w3.org
>
> This is the formalization of a proposal made on the mailing list on Sept 9.
>
> Proposal: Add output devices to the GetSources call, and add a "group"
> attribute for device grouping.
>
> Rules for attribute visibility should be as for GetSources.
>
> Example output:
>
> {
>    { 1234, "video", "First camera", group=42},
>    { 7654, "audio", "First camera microphone", group=42},
>    { 2345, "audio", "Headset microphone", group=17},
>    { 3697, "audioOut", "Headset speakers", group=17}
> }
>
> Here, the headset microphone and speaker are part of the same device.
>
> WebIDL changes:
>
> - Change name of call to GetDevices
> - Rename "SourceInfo" dictionary to "DeviceInfo"
> - Add an attribute of type DOMString called "group"
> - Add "audioOut" and "videoOut" as legal values for the "kind" attribute

Should getDevices() still hang of MediaStreamTrack now when we have 
introduced output devices as well? Perhaps it should be a sibling to 
getUserMedia() on Navigator?

// SourceInfo as of today for reference
dictionary SourceInfo {
     DOMString sourceId;
     DOMString kind;
     DOMString label;
};

sourceId: rename to "deviceId" or perhaps only "id" is sufficient since 
it hangs of a DeviceInfo object?

kind: Suggestion: explicitly state the type of device for input devices 
as well ("audio" -> "audio-input"). Then we might consider renaming 
"kind" to "type" since we're not aligned with MediaStreamTrack.kind anymore.

/Adam
Received on Friday, 4 October 2013 11:46:14 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:26:20 UTC