W3C home > Mailing lists > Public > public-ldp-wg@w3.org > September 2013

Re: ISSUE-81 Suggested Name Changes

From: Steve Speicher <sspeiche@gmail.com>
Date: Mon, 30 Sep 2013 09:41:32 -0400
Message-ID: <CAOUJ7Jrg=WE-gr758H6fGgfJEXeoPRq=MCGAb5W-uAs6GvDabA@mail.gmail.com>
To: David Wood <david@3roundstones.com>
Cc: "public-ldp-wg@w3.org Working Group" <public-ldp-wg@w3.org>
I moved the proposals into a Wiki page [1] so we could do some better
side-by-side comparisons.  I think we should be closed on what the
proposals are, there are a few questions I put inline with some of the
proposals (Miguel's and Ted's)

[1] - http://www.w3.org/2012/ldp/wiki/ISSUE-81

- Steve Speicher


On Sat, Sep 14, 2013 at 9:10 PM, David Wood <david@3roundstones.com> wrote:

> Hi all,
>
> This message attempts to collate suggested name changes for the membership
> predicates in ISSUE-81.
>
> ISSUE-81
> http://www.w3.org/2012/ldp/track/issues/81
>
> We seem to have developed consensus at FTF4 on leaving the design for
> ISSUE-81 as it is, but changing the names of the terms to be more clear.
>  The current terms are:
>
> ldp:membershipContainer
> ldp:membershipContainsRelation
> ldp:membershipContainedByRelation
> ldp:membershipMemberCreationIdentifier
>
> Suggested changes follow, annotated with the names of the people who
> suggested them.
>
> Ted:
> ldp:membershipSubject --> ldp:containmentContainer
> ldp:membershipPredicate --> ldp:containmentRelation
> ldp:membershipObject --> ldp:containmentAddedMember
> ldp:membershipPredicateInverse --> ldp:containmentMemberRelation
>
> John:
> (?c, ?p, member)
> ldp:container ?c
> ldp:containsRelation ?p
> # object (member) varies
>
> (member, ?p, ?c)
> # subject (member) varies
> ldp:containedByRelation ?p
> ldp:container ?c
>
> (?c, ?p, member from foaf:primaryTopic)
> ldp:container ?c
> ldp:containsRelation ?p
> ldp:insertedContentRelation foaf:primaryTopic
>
> Miguel:
> I would merge ldp:membershipSubject and ldp:membershipObject, as they
> always refer to the same resource, the one that aggregates the members:
>
> ldp:membershipSubject & ldp:membershipObject --> ldp:memberAggregator
> ldp:membershipPredicate --> ldp:memberAggregationRelation
> ldp:membershipPredicateInverse --> ldp:memberInverseAggregationRelation
>
> Roger:
> membershipSubject -> domainSelector (or maybe fromSelector, startSelector,
> originSelector ... )
> membershipObject -> rangeSelector (or maybe toSelector, endSelector,
> destinationSelector ...)
> membershipPredicate -> no change (?)
> membershipPredicateInverse -> no change (?)
>
> Regards,
> Dave
> --
> http://about.me/david_wood
>
>
>
>
Received on Monday, 30 September 2013 13:42:03 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:17:44 UTC