W3C home > Mailing lists > Public > public-ldp-wg@w3.org > September 2013

Re: ISSUE-81 Suggested Name Changes

From: Ted Thibodeau Jr <tthibodeau@openlinksw.com>
Date: Mon, 16 Sep 2013 16:29:07 -0400
Cc: "public-ldp-wg@w3.org Working Group" <public-ldp-wg@w3.org>
Message-Id: <2C31A978-FF6D-4564-BC3C-5765AE27704E@openlinksw.com>
To: David Wood <david@3roundstones.com>

On Sep 14, 2013, at 09:10 PM, David Wood wrote:

> Hi all,
> 
> This message attempts to collate suggested name changes for the membership predicates in ISSUE-81.
> 
> ISSUE-81
> http://www.w3.org/2012/ldp/track/issues/81
> 
> We seem to have developed consensus at FTF4 on leaving the design for ISSUE-81 as it is, but changing the names of the terms to be more clear.  The current terms are:
> 
> ldp:membershipContainer
> ldp:membershipContainsRelation
> ldp:membershipContainedByRelation
> ldp:membershipMemberCreationIdentifier

Those are actually another set of suggestsions, from me,
during on-channel brainstorming.

The current terms are 

   ldp:membershipSubject
   ldp:membershipPredicate
   ldp:membershipObject
   ldp:membershipPredicateInverse

And my final round was --

  ldp:membershipSubject          --> ldp:membershipContainerID
  ldp:membershipPredicate        --> ldp:membershipContainsRel
  ldp:membershipPredicateInverse --> ldp:membershipContainedByRel
  ldp:membershipObject           --> ldp:membershipNewMemberID

Be seeing you,

Ted


> Suggested changes follow, annotated with the names of the people who suggested them.
> 
> Ted:
> ldp:membershipSubject --> ldp:containmentContainer
> ldp:membershipPredicate --> ldp:containmentRelation
> ldp:membershipObject --> ldp:containmentAddedMember
> ldp:membershipPredicateInverse --> ldp:containmentMemberRelation
> 
> John:
> (?c, ?p, member)
> ldp:container ?c
> ldp:containsRelation ?p
> # object (member) varies
> 
> (member, ?p, ?c)
> # subject (member) varies
> ldp:containedByRelation ?p
> ldp:container ?c
> 
> (?c, ?p, member from foaf:primaryTopic)
> ldp:container ?c
> ldp:containsRelation ?p
> ldp:insertedContentRelation foaf:primaryTopic
> 
> Miguel:
> I would merge ldp:membershipSubject and ldp:membershipObject, as they always refer to the same resource, the one that aggregates the members:
> 
> ldp:membershipSubject & ldp:membershipObject --> ldp:memberAggregator
> ldp:membershipPredicate --> ldp:memberAggregationRelation
> ldp:membershipPredicateInverse --> ldp:memberInverseAggregationRelation
> 
> Roger:
> membershipSubject -> domainSelector (or maybe fromSelector, startSelector, originSelector ... )  
> membershipObject -> rangeSelector (or maybe toSelector, endSelector, destinationSelector ...) 
> membershipPredicate -> no change (?) 
> membershipPredicateInverse -> no change (?) 
> 
> Regards,
> Dave
> --
> http://about.me/david_wood
> 
> 
> 

--
A: Yes.                      http://www.guckes.net/faq/attribution.html
| Q: Are you sure?
| | A: Because it reverses the logical flow of conversation.
| | | Q: Why is top posting frowned upon?

Ted Thibodeau, Jr.           //               voice +1-781-273-0900 x32
Senior Support & Evangelism  //        mailto:tthibodeau@openlinksw.com
                             //              http://twitter.com/TallTed
OpenLink Software, Inc.      //              http://www.openlinksw.com/
         10 Burlington Mall Road, Suite 265, Burlington MA 01803
     Weblog   -- http://www.openlinksw.com/blogs/
     LinkedIn -- http://www.linkedin.com/company/openlink-software/
     Twitter  -- http://twitter.com/OpenLink
     Google+  -- http://plus.google.com/100570109519069333827/
     Facebook -- http://www.facebook.com/OpenLinkSoftware
Universal Data Access, Integration, and Management Technology Providers








Received on Monday, 16 September 2013 20:29:31 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:17:44 UTC