W3C home > Mailing lists > Public > public-ldp-wg@w3.org > September 2013

Re: ISSUE-81 Suggested Name Changes

From: Steve Speicher <sspeiche@gmail.com>
Date: Mon, 16 Sep 2013 08:13:31 -0400
Message-ID: <CAOUJ7Jp7O3Th3wA=bux4jy5EY1arZLQMsRwPmHO13RaY+0r9hQ@mail.gmail.com>
To: David Wood <david@3roundstones.com>
Cc: "public-ldp-wg@w3.org Working Group" <public-ldp-wg@w3.org>
Hi,

On Sat, Sep 14, 2013 at 9:10 PM, David Wood <david@3roundstones.com> wrote:

> Hi all,
>
> This message attempts to collate suggested name changes for the membership
> predicates in ISSUE-81.
>
> ISSUE-81
> http://www.w3.org/2012/ldp/track/issues/81
>
> We seem to have developed consensus at FTF4 on leaving the design for
> ISSUE-81 as it is, but changing the names of the terms to be more clear.
>  The current terms are:
>
> ldp:membershipContainer
> ldp:membershipContainsRelation
> ldp:membershipContainedByRelation
> ldp:membershipMemberCreationIdentifier
>
> Suggested changes follow, annotated with the names of the people who
> suggested them.
>

So no consensus on what they should be?  Is the plan to kick around some of
these, get more feedback and try to reach consensus at one of the upcoming
telecons?  It looks like that was the conclusion of day 2 on this topic [1]
I'd assume this implies there are 6 proposals on the table: 1) my original
one in issue-81 writeup 2) Henry's from email and 3-6 below (Ted, John,
Miguel, Roger).

[1] http://www.w3.org/2013/meeting/ldp/2013-09-13#ISSUE__2d_81

-Steve Speicher


> Ted:
> ldp:membershipSubject --> ldp:containmentContainer
> ldp:membershipPredicate --> ldp:containmentRelation
> ldp:membershipObject --> ldp:containmentAddedMember
> ldp:membershipPredicateInverse --> ldp:containmentMemberRelation
>
> John:
> (?c, ?p, member)
> ldp:container ?c
> ldp:containsRelation ?p
> # object (member) varies
>
> (member, ?p, ?c)
> # subject (member) varies
> ldp:containedByRelation ?p
> ldp:container ?c
>
> (?c, ?p, member from foaf:primaryTopic)
> ldp:container ?c
> ldp:containsRelation ?p
> ldp:insertedContentRelation foaf:primaryTopic
>
> Miguel:
> I would merge ldp:membershipSubject and ldp:membershipObject, as they
> always refer to the same resource, the one that aggregates the members:
>
> ldp:membershipSubject & ldp:membershipObject --> ldp:memberAggregator
> ldp:membershipPredicate --> ldp:memberAggregationRelation
> ldp:membershipPredicateInverse --> ldp:memberInverseAggregationRelation
>
> Roger:
> membershipSubject -> domainSelector (or maybe fromSelector, startSelector,
> originSelector ... )
> membershipObject -> rangeSelector (or maybe toSelector, endSelector,
> destinationSelector ...)
> membershipPredicate -> no change (?)
> membershipPredicateInverse -> no change (?)
>
> Regards,
> Dave
> --
> http://about.me/david_wood
>
>
>
>
Received on Monday, 16 September 2013 12:14:02 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:17:44 UTC