W3C home > Mailing lists > Public > public-ldp-wg@w3.org > January 2013

Re: Interaction model vs data model

From: Henry Story <henry.story@bblfish.net>
Date: Thu, 24 Jan 2013 13:54:55 +0100
Cc: "Eric Prud'hommeaux" <eric@w3.org>, Arnaud Le Hors <lehors@us.ibm.com>, "public-ldp-wg@w3.org" <public-ldp-wg@w3.org>
Message-Id: <3AEC5A06-92A7-4B9C-8BEE-0156EAD7A51B@bblfish.net>
To: "Wilde, Erik" <Erik.Wilde@emc.com>

On 24 Jan 2013, at 13:44, "Wilde, Erik" <Erik.Wilde@emc.com> wrote:

> hello all.
> On 2013-01-24 13:32 , "Henry Story" <henry.story@bblfish.net> wrote:
>>> I think that we are making only trivial statements about type if one
>>> can't predict some opperational behavior from that type. The most
>>> practical type I can imagine is one that tells me if POSTing RDF will
>>> append it (LDPR) or submit a new element to a container (LDPC).  To
>>> that end, I think that LDPC and LDPR are sibling resources with some
>>> common ancestor. It's probably worth identifying that ancestor as it
>>> has a few properties common to both LDPCs and LDPRs, namely that GET
>>> gets you some relevant RDF and that it's defined by LDP.
>> Exactly :-) Thanks for making this clear.
>>>> For what it's worth, section 5.2.1 of the LDP spec [2] states that "A
>>>> Linked Data Platform Container must also be a conformant Linked Data
>>>> Platform Resource." I've always read that as meaning that an LDPC is
>>>> an 
>>>> LDPR.
>>>> What am I missing?
>> I think it is possible that as things change and as we formalise things,
>> we notice that there are incompatibilities in terms of operational
>> behavior between different types of things that we had not noticed
>> earlier. 
>> It is pretty tricky. We may even find that new types of things start
>> emerging,...
> i think this kind of exercise might be very useful. however, it would be
> unfortunate if our re-defined ontology would say that an LDPR is something
> and that an LDPC is something else, and that both have a common ancestor.
> i am simply saying this because in the REST community, the term "resource"
> is very well established, and everything that has a URI is a resource.
> thus, to say that we have LDPC "things" that have URIs but are not
> resources certainly would cause quite a bit of confusion for readers of
> the spec.

I agree. That would not be the way to go.
Perhaps ldp:Content would be a better name for whatever is not an 
ldp:Container but is an ldp:Resource .

 ldp:Content rdfs:subClassOf ldp:Resource;
     owl:disjointWith ldp:Container .

If one then had say an ldp:contains relation 

  ldp:contains rdfs:subPropertyOf rdfs:member ;
        rdfs:domain ldp:Container .

then one could think of the ldp:contains relation
forming a tree with ldp:Content elements as the leaves .

> cheers,
> dret.

Social Web Architect

Received on Thursday, 24 January 2013 12:55:30 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:17:36 UTC