W3C home > Mailing lists > Public > public-ldp-wg@w3.org > December 2013

ISSUE-89 - proposal 3 - propertiesOnlyResource

From: Henry Story <henry.story@bblfish.net>
Date: Tue, 10 Dec 2013 00:40:25 +0100
Message-Id: <DE617C73-7E0E-4DB0-89B5-D631CE502575@bblfish.net>
To: Linked Data Platform WG <public-ldp-wg@w3.org>
Alexandre, would this be something like the correct definition of
ldp:propertiesOnlyResource ?

 ldp:propertiesOnlyResource a ldp:Container;
    rdfs:domain ldp:Container;
    rdfs:range ldp:Resource; // <- understood as ISSUE-90 LDPR
    rdf:comment """
      relates an LDP Container to the resource listing the "membership triples",
      a.k.a properties-only resource .
    """ . 

I just realised that this relation can have another use too. The header 
of the propertiesresource could also link back to the LDPC using the 
same relation, but using it in the reverse direction.
( see http://tools.ietf.org/search/rfc5988 )
To use your the example from issue-90

------------8<------------------------------
$ curl -i http://example.org/container1/
...
Content-Type: text/turtle; charset=UTF-8
Link: <http://www.w3.org/ns/ldp#Container>; rel="type"
Link: <?properties-only>; rel="http://www.w3.org/ns/ldp#propertiesOnlyResource"

...
@prefix dcterms: <http://purl.org/dc/terms/>.
@prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#>.
@prefix ldp: <http://www.w3.org/ns/ldp#>.

<>
  a ldp:SimpleContainer;
  dcterms:title "A very simple container";
  ldp:contains <member1>, <member2>, <member3>.
------------>8------------------------------


Then 

------------8<------------------------------
$ curl -i http://example.org/container1/?propertiesOnly
...
Content-Type: text/turtle; charset=UTF-8
Link: <.>; rev="http://www.w3.org/ns/ldp#propertiesOnlyResource"

<>
  a o:NetWorth;
  o:netWorthOf <http://example.org/users/JohnZSmith>;
  o:asset
     <assetContainer/a1>,
     <assetContainer/a2>;
  o:liability
     <liabilityContainer/l1>,
     <liabilityContainer/l2>,
     <liabilityContainer/l3>.
------------>8------------------------------

Otherwise though I think we need to get a better name for "membership properties"
I don't think that "properties only" gets it quite right either.  But that's
another issue probably.

Social Web Architect
http://bblfish.net/
Received on Monday, 9 December 2013 23:41:09 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:11:54 UTC