W3C home > Mailing lists > Public > public-html@w3.org > June 2009

[Bug 7062] New: replace terms "CDATA element" and "RCDATA element" with... something better

From: <bugzilla@wiggum.w3.org>
Date: Mon, 29 Jun 2009 02:53:38 +0000
To: public-html@w3.org
Message-ID: <bug-7062-2495@http.www.w3.org/Bugs/Public/>

           Summary: replace terms "CDATA element" and "RCDATA element"
                    with... something better
           Product: HTML WG
           Version: unspecified
          Platform: PC
               URL: http://www.whatwg.org/specs/web-apps/current-
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HTML5 spec proposals
        AssignedTo: dave.null@w3.org
        ReportedBy: mike@w3.org
         QAContact: public-html-bugzilla@w3.org
                CC: ian@hixie.ch, mike@w3.org, public-html@w3.org


The current draft uses the terms "CDATA element" to describe <script> and
<style> elements, and "RCDATA element" to describe <title> and <textarea>

I think it would be good to consider replacing those with other terms.

The problem is that "CDATA" already has a number of meanings[1] that conflict
with one another.


So it seems less than ideal to introduce a new term that potentially adds even
more ambiguity and confusion around what "CDATA" means.

All that said, I can't at the moment think of any better terms with which to
replace CDATA and RCDATA and that would themselves be accurate and less

But maybe other people have some some specific suggestions.

Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Monday, 29 June 2009 02:53:50 UTC

This archive was generated by hypermail 2.4.0 : Saturday, 9 October 2021 18:44:49 UTC