W3C home > Mailing lists > Public > public-html-media@w3.org > September 2012

[EME] Bug 18531 - rename addKey method

From: Mark Watson <watsonm@netflix.com>
Date: Tue, 4 Sep 2012 15:28:24 +0000
To: "<public-html-media@w3.org>" <public-html-media@w3.org>
Message-ID: <93CBDA15-A076-4510-B7C2-2E78D3993C34@netflix.com>

The addKey method can be used for more than just providing a key. Specifically
it can be used for
- providing a key
- providing a license
- updating a license or other CDM session state

As a result the addKey name is confusing.

In general, the purpose of this method is to provide a message to the CDM that
updates the session state in some CDM-specific way. With the object-oriented
model, sessions are explicitly represented by session objects and addKey is a
method on that object.

With that context we could rename the method to something simple.

Proposals so far:

- update() (as in update the session state)

- addData() (as in provide some information to the session)

Comments, preferences, other suggestions ?

Received on Tuesday, 4 September 2012 15:28:56 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 15:48:26 UTC