W3C home > Mailing lists > Public > public-html-media@w3.org > August 2012

[Bug 18531] New: Consider renaming addKey method

From: <bugzilla@jessica.w3.org>
Date: Fri, 10 Aug 2012 18:38:01 +0000
To: public-html-media@w3.org
Message-ID: <bug-18531-5436@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=18531

           Summary: Consider renaming addKey method
           Product: HTML WG
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Encrypted Media Extensions
        AssignedTo: adrianba@microsoft.com
        ReportedBy: watsonm@netflix.com
         QAContact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html-media@w3.org


The addKey method can be used for more than just providing a key. Specifically
it can be used for
- providing a key
- providing a license
- updating a license or other CDM session state

As a result the addKey name is confusing.

In general, the purpose of this method is to provide a message to the CDM that
updates the session state in some CDM-specific way. With the object-oriented
model, sessions are explicitly represented by session objects and addKey is a
method on that object. With that context we could rename the method to
something as simple as update() - it is a method on the session object so the
implication is that it updates the session somehow.

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Friday, 10 August 2012 18:38:03 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 15:48:25 UTC