W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > February 2010

[Bug 8731] Consider expanding buffering control for media elements

From: <bugzilla@wiggum.w3.org>
Date: Sun, 14 Feb 2010 06:53:08 +0000
To: public-html-bugzilla@w3.org
Message-Id: <E1NgYLs-0002PK-2d@wiggum.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=8731





--- Comment #13 from Maciej Stachowiak <mjs@apple.com>  2010-02-14 06:53:07 ---
(In reply to comment #11)
> Proposal based on reading the long mailing-list thread and all the comments on
> this bug:
> 
> We drop the autobuffer and autoplay attributes and replace them with one
> enumerated attribute called "loadhint", which takes the following values:
> 
>    loadhint=none*      -- load nothing
>    loadhint=minimal*   -- load duration and size information only
>    loadhint=autobuffer -- load at least enough to play through
>    loadhint=autoplay   -- same as autoplay="" today
> 
> (* I don't especially like the values "none" and "minimal", if anyone has any
> clearly better suggestions please let me know)
> 

I'm not sure it makes sense to merge autoplay into the same attribute. autoplay
affects behavior, it is not just a hint about how much to load. (It's true that
strictly speaking UAs may ignore autoplay, but it seems to be at a lesser level
of hint-ness and a separate concern from how much to preload).

I also do not like "autobuffer" as a value name. It's not any more or less
automatic than the others. I think loadhint=playthrough would be better.

I also think "loadhint" as a name for the attribute is less clear than
"preload".


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Sunday, 14 February 2010 06:53:09 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 20:01:11 UTC