W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > August 2010

[Bug 10365] New: popstate event fires after onload (first page visit) -- intended behavior? would be annoying if there was a script that ajax loaded a page at onpopstate, and hand typing in a url, the page is returned by the server, and then onpopstate fires after onload,

From: <bugzilla@jessica.w3.org>
Date: Sat, 14 Aug 2010 12:19:58 +0000
To: public-html-bugzilla@w3.org
Message-ID: <bug-10365-2486@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=10365

           Summary: popstate event fires after onload (first page visit)
                    -- intended behavior? would be annoying if there was a
                    script that ajax loaded a page at onpopstate, and hand
                    typing in a url, the page is returned by the server,
                    and then onpopstate fires after onload,
           Product: HTML WG
           Version: unspecified
          Platform: Other
               URL: http://www.whatwg.org/specs/web-apps/current-work/#eve
                    nt-popstate
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P3
         Component: HTML5 spec (editor: Ian Hickson)
        AssignedTo: ian@hixie.ch
        ReportedBy: contributor@whatwg.org
         QAContact: public-html-bugzilla@w3.org
                CC: mike@w3.org, public-html@w3.org


Section: http://www.whatwg.org/specs/web-apps/current-work/#event-popstate

Comment:
popstate event fires after onload (first page visit) -- intended behavior?
would be annoying if there was a script that ajax loaded a page at onpopstate,
and hand typing in a url, the page is returned by the server, and then
onpopstate fires after onload, and the browser/javascript requests the same
page again with ajax.  I think popstate should not fire after onload.  if a
script needs it then they should attach to both onpopstate and onload instead.

Posted from: 219.77.175.157

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Saturday, 14 August 2010 12:20:00 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 20:01:21 UTC