W3C home > Mailing lists > Public > public-fx@w3.org > October to December 2015

Re: [geometry] Name of DOMMatrix and related classes is out of place.

From: Simon Pieters <simonp@opera.com>
Date: Tue, 03 Nov 2015 11:23:15 +0100
To: public-fx@w3.org, /#!/JoePea <trusktr@gmail.com>
Message-ID: <op.x7isg1eoidj3kv@simons-mbp>
On Thu, 29 Oct 2015 01:54:55 +0100, /#!/JoePea <trusktr@gmail.com> wrote:

> In some contexts, the "DOM" in DOMMatrix feels out of place, for example  
> in
> WebGL. Why not call it something like TransformationMatrix,
> GraphicalMatrix, Matrix3D, or something more generic like that so the  
> name
> is agnostic of where you are using the class. I'm not manipulating DOM
> inside of a WebGL context.
> I made discussion about this on Discourse:
> http://discourse.wicg.io/t/the-name-of-dommatrix-is-out-of-place/1169

A few points:

* I think the name should be consistent between the various interfaces in  
the Geometry spec.
* We can't use no prefix at all because Web content already uses "Point",  
"Matrix", etc.
* "DOM" is typically understood to include everything that is defined in  
terms of WebIDL these days, not just the objects that are descendants of  
* "DOMString" is a name that is used for all strings in the Web platform,  
and this hasn't been a problem in practice (although that name is not  
visible to JS).
* The common interactions with DOMMatrix will not involve touching the  
name itself, but more use methods called e.g. "transformMatrix" and so on.
* These names have been bikeshedded in the past, where we concluded that  
"DOM" prefix was least bad (it's short, globally applicable).

All in all, I agree that it's not ideal (I would have preferred no prefix  
if the Web hadn't claimed the names), but I'm not convinced that it is a  
good idea to change the name of DOMMatrix at this point. In particular, I  
disagree that the name is inappropriate for 2d canvas or WebGL.

Simon Pieters
Opera Software
Received on Tuesday, 3 November 2015 10:23:51 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 3 November 2015 10:23:51 UTC