Re: [motion-path] More natural names for 'auto' and 'reverse'

2015-06-22 9:47 GMT+03:00 Shane Stephens <>:
> I think this is so that you *can* move the motion path if you need to. If
> motion came first then you'd need to resort to nested divs or similar.

I think the translate, rotate, and scale properties were designed to
help authors to write the most common use cases easily, not to provide
more flexibility.

To rotate and scale an object along a motion path is a very common use.

Also, I think this can happen a lot: I have animated an object with
translate, rotate and scale and then later want to switch from a
simple translate animation to a fancy motion path animation. I can’t
simply change the translate property to a motion property. Instead, I
need to create a wrapper div for the motion property.

I just think that these are common use cases which should be made
easy. After all, one of the main purposes of CSS Transform Module
Level 2 is to make authoring easier: "authors no longer have to
remember the ordering of these transform functions" [1].

>> Also, should 'motion-rotation’ be 'motion-rotate' to match ’rotate’?
>> Will the different ways to name things be confusing?
> Yes, I think it probably should. I'll update it along with any other changes
> that come out of this thread.

On the other hand, property names are supposed to be nouns. If the
motion property won’t include the rotation angle, then maybe
‘motion-rotation’ is ok, since it won’t have such a strong association
with 'rotate’ anymore. Or maybe call it something completely
different, like ‘motion-orientation’ with values ’none’ and ‘path’.
Well, I don’t know.. :)



Received on Monday, 22 June 2015 10:42:38 UTC