Re: [web-animations] AnimationTimeline comments

Let me rephrase: it would make more sense to me to provide an object-getter
for this task than an object-creator, especially given the desire to
control/avoid memory allocations in code concerned with smooth animations.

- Kris

On Mon, May 19, 2014 at 9:58 AM, Boris Zbarsky <> wrote:

> On 5/19/14, 12:48 PM, Kristopher Giesing wrote:
>> It would make more sense to me for a method named "get" to return the
>> same object every time.
> This is backwards reasoning, just like reasoning from the IDL.
> First you should decide on the behavior you want.
> Then you name the method (and write the IDL) in whatever way best reflects
> that behavior.
> -Boris

Received on Monday, 19 May 2014 17:06:08 UTC