W3C home > Mailing lists > Public > public-fx@w3.org > July to September 2013

Re: [web-animations] Naming of timing groups in the API

From: Dean Jackson <dino@apple.com>
Date: Thu, 19 Sep 2013 10:12:42 -0700
Cc: "public-fx@w3.org" <public-fx@w3.org>
Message-id: <2565AC72-770E-4595-8DE8-D7036202FE75@apple.com>
To: Brian Birtles <bbirtles@mozilla.com>
I tend to think “Sequence” is a great name - it’s very clear.

The problem is mostly with par/Parallel/Group where there isn’t a fairly clear word to describe the idea. Apple’s recent SpriteKit API uses “group" for this construct.

SequentialGroup and ConcurrentGroup? yuck.


On 5 Sep 2013, at 11:13 pm, Brian Birtles <bbirtles@mozilla.com> wrote:

> Hi,
> A number of people have expressed concern about the names "ParGroup" and "SeqGroup" used in the Web Animations API for parallel timing groups and sequence timing groups so we are looking for better names.
> Some considerations:
> * It should be short--experience tells us authors hate typing long names and these are two interfaces we expect authors to type a lot.
> * It shouldn't clash with usage in existing libraries.
> * Within the spec we've used "animation" in a narrow sense to mean "actually applying an effect to a target element over time". So we have "timed items" but only timed items that actually apply an effect, e.g. interpolate a property value, are called "animations". The reasoning is that if you have some groups that sequence a series of videos and audio clips, do you really call that animation? It also matches the distinction we make between the timing model and animation model but feel free to question this naming.
> Some ideas thrown around so far:
> * Sequence and Parallel (might risk clashes? What is a "Parallel", it's not a noun so "new Parallel" is weird)
> * Sequence and Group (we'd have to call the superclass something else, but, who cares--no one ever types that)
> * TimingSequence and TimingGroup (unlikely to clash but long)
> * TimingSequence and TimingSet ?
> * AnimationSequence and AnimationGroup (conflicts with our narrow use of the term "animation")
> * Sequence and Timeline (and rename our existing "timeline" to "clock", e.g. document.clock.play(...) -- a bit weird?)
> * Sequence and Together
> * ???
> And while we're on the topic, there are a number of other interfaces where concern has been expressed about them possibly clashing:
> * Player
> * Timing
> * Timeline
> (Although note that none of these have constructors so authors won't currently be typing them meaning it's probably fine if they're longer.)
> Any thoughts welcome! We'll probably rename everything at LC anyway ;)
> Best regards,
> Brian
Received on Thursday, 19 September 2013 17:13:24 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:49:46 UTC