W3C home > Mailing lists > Public > public-fx@w3.org > October to December 2011

Re: CSS filter primitive evaluation

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Fri, 14 Oct 2011 16:34:56 -0700
Message-ID: <CAAWBYDCpaYzXck6kmo6Edx_cs4BWBOqJ9UnbgUgs9EHB3=gaTw@mail.gmail.com>
To: Chris Marrin <cmarrin@apple.com>
Cc: public-fx@w3.org
On Fri, Oct 14, 2011 at 4:23 PM, Chris Marrin <cmarrin@apple.com> wrote:
> 2) I think grayscale(v) is the same as saturate(1-v), so I think we should remove the grayscale() function. I know it's a very familiar concept. But I think it's ultimately just as easy to think of it as "I want to fully desaturate the color -> saturate(0)" as it is to say, "I want to fully grayscale the image -> grayscale(1)".

I support collapsing them, and agree that keeping saturate() is better.

> 3) We currently have hue-rotate() and saturate() functions. I think we should complete the set with a lightness() function, so we can manipulate all channels of the HLS color space. The reason I say HLS rather than HSV is only because "lightness" makes a better name than "value". I don't have enough experience with color models to know which of the two is preferable.
> 4) While we're at it, we might want to change the names to saturation() and hue() just for simplicity. It changes them from verbs to nouns, but there are already inconsistencies in this area (e.g., opacity vs sharpen). But I don't that's so bad. Trying to make these consistent might be one of those hobgoblin situations. I don't think using "opacify" or "sharpness" would help clarity any!

Both of these sound good.

(I don't have an opinion on the rest.)

Received on Friday, 14 October 2011 23:35:46 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:49:39 UTC