Element name for specifying properties on dispatch action


In March this year we agreed to add a mechanism to add properties to custom events when sending them using the dispatch action . We had chosen 'property'[1] as the name of the element, because the event()[2] function used to access the extra event data/parameters, calls the event data/parameters a properties. Some people weren't happy with the name though. Until now nobody came-up with an alternative that is wider accepted.

If you want another name for the element, please propose one now. We will discuss the new name on the list and at the next teleconf. If nobody responds, I'm going to remove the editorial note that states that 'The property child element is still under debate, the syntax will probably change in the future.'

Kind regards,

Nick Van den Bleeken
R&D Manager

Phone: +32 3 425 41 02
Office fax: +32 3 821 01 71

1: http://www.w3.org/MarkUp/Forms/wiki/XForms_2.0#The_property_Child_Element
2: http://www.w3.org/MarkUp/Forms/wiki/XPath_Expressions_Module#fn-event


Inventive Designers' Email Disclaimer:

Received on Thursday, 22 November 2012 10:51:07 UTC