W3C home > Mailing lists > Public > public-forms@w3.org > December 2008

Re: Updated draft of XML Data Island Module

From: Mark Birbeck <mark.birbeck@webbackplane.com>
Date: Wed, 10 Dec 2008 10:34:54 -0500
Message-ID: <ed77aa9f0812100734l7792037ao388a339f9b67c20f@mail.gmail.com>
To: "Charles F Wiecha" <wiecha@us.ibm.com>
Cc: public-forms <public-forms@w3.org>
Hi Charlie,

I'll not be able to make the call today, so I thought I'd forward some

1. It would be good to have a consistent naming/prefix pattern throughout
these modules. So in this case the spec is called "data islands", whilst the
event names begin "data-instance". I'm not saying which name is better, but
I'm just making the point that as we add modules it would be quite good for
developers if the naming matches.

(Having said that, I don't think we whould have the prefixes...see below.)

2. The editorial note says that we want to have non-XML data islands in the
future, and that's why events are named the way they are. But I think if
that is a serious goal, then the spec name should change. (As it happens, I
think we might fall foul of being too flexible, and it might be better to
let the future take care of itself, and focus on XML now.)

3. I think the "data-instance-ready" event might be mappable to the "load"
event from DOM 2 Events. I haven't double-checked, but my recollection of
the "load" event is that it's related to pretty much any object that has
completed loading, whether it's an image or whatever. So I think it would be
appropriate to use it here.

(Note also that DOM 2 Events has an "error" event, too.)

4. Do we need get/setInstanceDocument()? Why not just have a property, such
as .document? It's a minor thing, and probably all a matter of taste, but
since any use of this method will almost certainly be to do things like

  if ( instance.getInstanceDocument().documentElement ) {

then why not allow this instead:

  if ( instance.document.documentElement ) {

To me it feels more consistent with other specs.

5.  Since the document should have been loaded already, then load() is
misleading. If it's going to *reload* the document referred to by the URL,
then I think it should mirror the XForms "reset" action, and could probably
be called reset().

I think we still need a load() method, and that it should take a URI

7. I'm not convinced we should refer to things like how to control
namespaces using XForms submission, or that an event might be interpreted as
a fatal error in XForms; My preference would be to keep this spec as lean as
possible (and of course it might not always be a fatal error in XForms).



On Wed, Dec 10, 2008 at 9:48 AM, Charles F Wiecha <wiecha@us.ibm.com> wrote:

> For our telecon discussion today...Charlie
> *(See attached file: index-all.html)*
> Charles Wiecha
> Manager, Multichannel Web Interaction
> IBM T.J. Watson Research Center
> P.O. Box 704
> Yorktown Heights, N.Y. 10598
> Phone: (914) 784-6180, T/L 863-6180, Cell: (914) 320-2614
> wiecha@us.ibm.com

Mark Birbeck, webBackplane



webBackplane is a trading name of Backplane Ltd. (company number
05972288, registered office: 2nd Floor, 69/85 Tabernacle Street,
London, EC2A 4RR)
Received on Wednesday, 10 December 2008 15:35:31 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:13:59 UTC