Re: [deviceorientation] update rotationRate alpha, beta, gamma description to be the same as implementation

The change you are proposing will make the definition of alpha, bet, and gamma different between devicemotion and deviceorientation. Don't do it. It breaks the specification and virtually ensures that there will be errors going forward by programmers who expect the definition to be the same and/or who know what alpha, beta, and gamma conventionally refer to.

Instead, browser developers should be encouraged to fix their browsers by deprecating the old names and replacing with new names that are less likely to be confused. New names should be adopted, such as "xDegrees", "yDegrees" and "zDegrees", for both devicemotion and deviceorientation. (Using x, y, and z in the name, instead of beta, gamma, and alpha, will reduce confusion. Using "degrees" in the name will make it clear that this is referring to a rotation, and that the unit is degrees, not radians.)  There should be a note in the specification saying the old names are deprecated because old browsers did not implement them correctly. (Also there should be a note that rotation rate on one axis can not be calculated from two successive deviceorientation measurements just on that one axis. To help avoid incorrect implementations, include the correct formulas.)

GitHub Notification of comment by andybloch
Please view or discuss this issue at using your GitHub account

Received on Saturday, 25 August 2018 20:02:53 UTC