Re: [sensors] Don't allocate response objects to avoid triggering GC

> Because it doesn't help us with requirements 2) and 3) above, makes 
for more verbose code (sensor.reading.x instead of sensor.x)

As for 2) and 3) `sensor.reading.x ` is not any worse than `sensor.x` 
(is it?), however `sensor.x` (y, z) would semantically mean position 
of the sensor itself, not the obtained data.

> and makes mutable an object developers will/should think of as 

cannot `reading` be readonly?

GitHub Notification of comment by pozdnyakov
Please view or discuss this issue at using
 your GitHub account

Received on Wednesday, 7 December 2016 11:02:14 UTC