Re: getSimplePropertyValue : Suggested simplifications

As a way of simplifying the interface I would avoid in these convenience 
methods that receive strings as parameters to pass any kind of IRI, i.e. 
if someone want to ask something about an aspect or property that are 
not in the default vocabulary he will need to use the SimplePropertyRef 
class, so the methods would be:

      *public* SimplePropertyValues 
getSimplePropertyValues(SimpleEvidence evidence)

                  *throws* SystemException;

      *public* SimplePropertyValues 
getSimplePropertyValues(SimpleEvidence evidence,

                  String aspectName) *throws* NameException, 
SystemException;


      *public* SimplePropertyValues 
getSimplePropertyValues(SimpleEvidence evidence,

                  SimplePropertyRef[] properties) *throws* NameException,

                  SystemException;


The same would apply for getting a property value i.e. with the string 
convenience methods you will only be allowed to ask things in the 
default vocabulary and if you want to go to another voc you will need to 
instantiate a SimplePropertyRef.

This is the same approach that we took in Boston F2F for the fast food 
methods, so we have a previous resolution that applies here

Best Regards

Jo Rabin escribió:
>
> At the moment we have 4 overloaded calls:
>
>  
>
>       *public* SimplePropertyValues 
> getSimplePropertyValues(SimpleEvidence evidence)
>
>                   *throws* SystemException;
>
>  
>
>       *public* SimplePropertyValues 
> getSimplePropertyValues(SimpleEvidence evidence,
>
>                   String aspectIRI, String aspectName) *throws* 
> NameException,
>
>                   SystemException;
>
>  
>
>       *public* SimplePropertyValues 
> getSimplePropertyValues(SimpleEvidence evidence,
>
>                   String aspectName) *throws* NameException, 
> SystemException;
>
>      
>
>       *public* SimplePropertyValues 
> getSimplePropertyValues(SimpleEvidence evidence,
>
>                   SimplePropertyRef[] properties) *throws* NameException,
>
>                   SystemException;
>
>  
>
>  
>
>  
>
> I think it would be better if the first 3 were called 
> getKnownSimplePropertyValues  since the semantic is different from the 
> following which returns values for all specified propoerties?
>
>  
>
> Any views before I post an updated interface definition?
>
>  
>
> Jo
>
>  
>

Received on Tuesday, 26 February 2008 17:13:46 UTC