W3C home > Mailing lists > Public > public-data-shapes-wg@w3.org > May 2016

Re: Transitive?

From: Jim Amsden <jamsden@us.ibm.com>
Date: Tue, 17 May 2016 08:59:59 -0400
Message-Id: <201605171300.u4HD0GSw005027@d03av05.boulder.ibm.com>
To: public-data-shapes-wg@w3.org
That sounds good.

Jim Amsden, Senior Technical Staff Member
OSLC and Linked Lifecycle Data

From:   Holger Knublauch <holger@topquadrant.com>
To:     public-data-shapes-wg@w3.org
Date:   05/16/2016 06:33 PM
Subject:        Re: Transitive?

My default interpretation of terms like "instance" is to include 
transitivity, and I believe this is also what the majority of readers 
would expect. To express the "direct" relationship, we would use something 
like "has a <a>value</a> X for <code>rdf:type</code>".

We added the prefix "SHACL" or "transitive" to distinguish our meaning 
from the full RDFS meaning with inferences such as sub-properties of 

I would also favor Dimitris' proposal of defining the verbose terms in the 
top only, because we already have hyperlinks which are unambiguous. Many 
documents state "For the remainder of this document, we use the following 
definitions..." so if people misunderstand things, then they have not read 
the full document. Not our problem then, from a formal point of view. This 
isn't for casual readers.

So we have 3 proposals now and could do a RESOLUTION in the next meeting 
as to what variation to use for the next publication cycle.


On 16/05/2016 23:00, Jim Amsden wrote:
I seems redundant to define a property as transitive and then use that as 
a prefix on every use of the property. Begs the question of what subclass, 
type, or instance isn't transitive, or what those words mean if the prefix 
word is missing.

Jim Amsden, Senior Technical Staff Member
OSLC and Linked Lifecycle Data

From:        Holger Knublauch <holger@topquadrant.com>
Date:        05/16/2016 08:11 AM
Subject:        Transitive?

Our recent editorial experiments were to use the terms SHACL instance, 
SHACL type and SHACL subclass. I don't find this very attractive to read 
and it gives room to misinterpretation too, e.g. people could read it as 
if we were using different properties than rdf:type or rdfs:subClassOf.

Looking at the RDFS spec [1], we can read

    "The rdfs:subClassOf property is transitive".

This is exactly the relevant bit of "inferencing" that we are using in 
SHACL too.

So why can't we switch to the terms

- transitive subclass
- transitive type
- transitive instance

which should be relatively unambiguous esp given that each usage of 
these terms is now hyperlinked to the terminology section. Furthermore 
transitivity even carries a fairly appropriate meaning:



[1] https://www.w3.org/TR/rdf-schema/#ch_subclassof
Received on Tuesday, 17 May 2016 13:06:53 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:30:33 UTC